We are investigting reports of connectivity issues for Teamwork Chat in our EU region
Incident Report for Teamwork.com
Resolved
Connectivity issues for Chat in our EU region have been resolved
Posted Feb 25, 2022 - 08:12 UTC
Investigating
We are investigting reports of connectivity issues for Teamwork Chat in our EU region
Posted Feb 25, 2022 - 07:42 UTC
This incident affected: Teamwork Chat (Teamwork Chat - EU Region).