Custom domain service in our EU region experiencing slow downs
Incident Report for Teamwork.com
Resolved
Our custom domain service has been scaled up to handle the increase in traffic from additional users and is currently stable.
Posted Sep 12, 2019 - 11:09 UTC
Investigating
Custom domain service in our EU region experiencing slow downs
Posted Sep 12, 2019 - 10:43 UTC
This incident affected: Teamwork Projects (Teamwork Projects - EU Region).