We are investigating reports of slow response times from Teamwork in our US region
Incident Report for Teamwork.com
Resolved
One of our databases clusters was experiencing higher than normal traffic and we have scaled up a little to compensate. We will continue to monitor.
Posted Aug 31, 2020 - 15:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 31, 2020 - 14:36 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).