We are experiencing slow response times for Teamwork Chat in our US region
Incident Report for Teamwork.com
Resolved
Teamwork Chat has returned to normal response times in our US region now as our infrastructure has scaled up to meet demands
Posted Mar 19, 2021 - 10:49 UTC
Identified
We are experiencing slow response times for Teamwork Chat in our US region and are working on a solution
Posted Mar 19, 2021 - 10:00 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region).