Teamwork Desk

Incident Report for Teamwork.com

Resolved

We have implemented a fix and are monitoring results.
Posted 6 days ago. Apr 01, 2025 - 17:25 UTC

Update

We are continuing to investigate this issue.
Posted 6 days ago. Apr 01, 2025 - 17:08 UTC

Investigating

We are currently investigating loading issues with Teamwork Desk
Posted 6 days ago. Apr 01, 2025 - 17:06 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).