We are investigating reports of outbound emails from Teamwork Desk not sending
Incident Report for Teamwork.com
Resolved
The issue has been identified and a fix is being implemented.
Posted Feb 07, 2023 - 13:57 UTC
Update
We are continuing to investigate this issue.
Posted Feb 07, 2023 - 11:28 UTC
Investigating
We are currently investigating this issue.
Posted Feb 07, 2023 - 11:26 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).