We are experiencing delays of inbound emails in to Teamwork Desk due to an upstream provider
Incident Report for Teamwork.com
Resolved
An issue with our provider has been resolved and email delivery has returned to a normal level.
Posted May 06, 2020 - 18:59 UTC
Update
We continue to work on this issue with our provider. Most emails are processing normally however we continue to see a delay in delivery for a small number of customers.
Posted May 06, 2020 - 15:59 UTC
Identified
We are experiencing delays of inbound emails in to Teamwork Desk due to an upstream provider
Posted May 06, 2020 - 12:45 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).