We are investigating performance issues in Teamwork in our US region
Incident Report for Teamwork.com
Resolved
Performance has returned to normal now after issues with an upstream provider.
Posted Feb 04, 2021 - 14:23 UTC
Investigating
We are investigating performance issues in Teamwork in our US region
Posted Feb 04, 2021 - 13:42 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).