We are investigating reports of connectivity issues in our US region
Incident Report for Teamwork.com
Resolved
Connection levels have returned to normal now after a connection issues to a database in our US region.
Posted Dec 13, 2021 - 04:46 UTC
Monitoring
We have resolved a connection issue in our US region and are monitoring for further isues
Posted Dec 13, 2021 - 04:00 UTC
Investigating
We are investigating reports of connectivity issues in our US region
Posted Dec 13, 2021 - 03:30 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region), Teamwork Desk (Teamwork Desk - US Region), and Teamwork Chat (Teamwork Chat - US Region).