We are investigating reports of downgraded performance on Notebooks in Teamwork Projects US region
Incident Report for Teamwork.com
Resolved
We have rolled back a recent deployment while we investigate the issue with Notebooks
Posted Oct 24, 2019 - 14:55 UTC
Investigating
We are investigating reports of downgraded performance on Notebooks in Teamwork Projects US region
Posted Oct 24, 2019 - 14:25 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).