Loading Issue with Teamwork Desk and Chat

Incident Report for Teamwork.com

Resolved

Our team have investigated, implemented a fix and resolved the issue.
Posted Jul 15, 2025 - 14:57 UTC

Investigating

We are currently investigating loading issues with Teamwork Desk and Chat. Our engineers are working on a solution.
Posted Jul 15, 2025 - 14:31 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region) and Teamwork Chat (Teamwork Chat - US Region).