Possible outbound Desk email issues in the EU region
Incident Report for Teamwork.com
Resolved
A backlog in Teamwork Desk notifications have now been fully processed in the EU region
Posted Nov 14, 2019 - 20:16 UTC
Investigating
We are currently investigating issues with outbound mail in the EU region
Posted Nov 14, 2019 - 14:24 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region).