Load issues - EU region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Sep 09, 2021 - 11:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 09, 2021 - 11:17 UTC
Investigating
We are currently seeing some load issues on our EU App servers
Posted Sep 09, 2021 - 11:04 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region) and Teamwork Projects (Teamwork Projects - EU Region).