We are monitoring slow response times from Teamwork Chat in our US region
Incident Report for Teamwork.com
Resolved
Teamwork Chat response times are back within normal limits now.
Posted Mar 23, 2021 - 11:05 UTC
Monitoring
We are monitoring slow response times from Teamwork Chat in our US region
Posted Mar 23, 2021 - 09:30 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region).