Slow load
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Aug 29, 2022 - 14:24 UTC
Investigating
We currently see slow load times for Teamwork Desk on our US servers.
Posted Aug 29, 2022 - 14:02 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).