Teamwork Slow Loading Issue

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 20:00 UTC

Update

Our team have implemented a fix and are monitoring the results
Posted Jan 12, 2026 - 17:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2026 - 17:13 UTC

Investigating

We are currently investigating slow loading in the US region.
Posted Jan 12, 2026 - 16:51 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).