We are investigating reports of issues in Teamwork Desk in our EU region
Incident Report for Teamwork.com
Resolved
Some temporary database connection issues have been solved now.
Posted 12 days ago. Oct 07, 2019 - 19:59 UTC
Investigating
We are investing reports of issues in Teamwork Desk in our EU region
Posted 12 days ago. Oct 07, 2019 - 19:24 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region).