We are currently investigating issues with Desk in our US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved
Posted Mar 18, 2024 - 15:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2024 - 14:15 UTC
Investigating
We are currently investigating issues with Desk
Posted Mar 18, 2024 - 13:57 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).