Connectivity issues with Chat in the US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 11:36 UTC
Update
We are continuing to investigate this issue.
Posted Jun 08, 2020 - 11:35 UTC
Update
We are continuing to investigate this issue.
Posted Jun 08, 2020 - 11:31 UTC
Investigating
We are currently investigating this issue.
Posted Jun 08, 2020 - 11:27 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region).