We are investigating reports of Teamwork Desk responding slowly in both US and EU regions
Incident Report for Teamwork.com
Resolved
Teamwork Desk is responding normally with no new reports of incidents from users.
Posted Feb 12, 2020 - 14:47 UTC
Investigating
We are investigating reports of Teamwork Desk responding slowly in both US and EU regions
Posted Feb 12, 2020 - 11:33 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).