We are investigating reports of users unable to log in to Teamwork Desk in our US region
Incident Report for Teamwork.com
Resolved
We experienced an issue with a Redis cache node in a particular zone. We failed over to a node in another zone to restore function.
Posted May 03, 2020 - 10:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2020 - 10:02 UTC
Investigating
We are investigating reports of users unable to log in to Teamwork Desk in our US region
Posted May 03, 2020 - 09:09 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).