We are investigating reports of authentication errors in Teamwork Projects

Incident Report for Teamwork.com

Resolved

Issues with authentication in Teamwork Projects have been resolved now.
Posted 6 years ago. Dec 13, 2018 - 10:11 UTC

Investigating

We are investigating reports of authentication errors in Teamwork Projects
Posted 6 years ago. Dec 13, 2018 - 09:54 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).