We are investigating time outs for users of custom domains in the EU region
Incident Report for Teamwork.com
Resolved
Custom domains in the EU region are operating normally now. A configuration error was found and removed.
Posted Aug 31, 2020 - 13:51 UTC
Investigating
We are investigating time outs for users of custom domains in the EU region
Posted Aug 31, 2020 - 13:30 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region) and Teamwork Projects (Teamwork Projects - EU Region).