Errors in Teamwork Desk

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Mar 08, 2022 - 16:18 UTC

Update

Resolved
Posted Mar 08, 2022 - 16:18 UTC

Investigating

We are currently investigating this issue.
Posted Mar 08, 2022 - 15:48 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).