We are currently investigating issues with Teamwork in our US region
Incident Report for Teamwork.com
Resolved
We received some higher than usual traffic to one of our databases, impacting on performance for a number of customers. We have resolved this issue now and performance is back to normal.
Posted Sep 21, 2020 - 16:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 21, 2020 - 15:08 UTC
Investigating
We are currently investigating this issue.
Posted Sep 21, 2020 - 15:01 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).