We are monitoring issues with one of our upstream providers impacting on performance in our EU region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 23:07 UTC
Monitoring
We are monitoring issues with one of our upstream providers impacting on performance in our EU region
Posted Aug 31, 2021 - 21:52 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region) and Teamwork Projects (Teamwork Projects - EU Region).