Slow load times
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 14:40 UTC
Investigating
We are currently investigating this issue.
Posted Nov 11, 2021 - 14:36 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region), Teamwork Chat (Teamwork Chat - US Region), and Teamwork Desk (Teamwork Desk - US Region).