We are investigating reports of connectivity issues in our EU region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Jul 03, 2021 - 21:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2021 - 18:28 UTC
Identified
We have identified the cause of connectivity issues in our EU region. A cluster upgrade has had some unexpected DNS issues. We are currently rolling back our maintenance changes.
Posted Jul 03, 2021 - 16:26 UTC
Investigating
We are investigating reports of connectivity issues in our EU region
Posted Jul 03, 2021 - 15:29 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region), Teamwork Projects (Teamwork Projects - EU Region), Teamwork Chat (Teamwork Chat - EU Region), and Launchpad (Launchpad - EU Region).