We are investigating reports of slow response times for Launchpad in our US region
Incident Report for Teamwork.com
Resolved
We have solved an issue with poor performance in one of our databases and response times have returned to normal.
Posted Jun 01, 2021 - 20:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 01, 2021 - 19:37 UTC
This incident affected: Launchpad (Launchpad - US Region).