We are investigating reports of slow load times for Desk in our US region
Incident Report for Teamwork.com
Resolved
We have rolled back a deployment which introduced a slow down loading Desk. Desk is operating normally now.
Posted Jun 29, 2020 - 15:38 UTC
Investigating
We are investigating reports of slow load times for Desk in our US region
Posted Jun 29, 2020 - 15:31 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).