We are investigating reports of slow downs in our US region
Incident Report for Teamwork.com
Resolved
We have resolved the issue of slow response times now as response times have remained stable.
Posted Apr 16, 2020 - 18:14 UTC
Monitoring
We have identified the cause of the slow downs and have a fix in place. We will monitor the response times for a short while before resolving fully.
Posted Apr 16, 2020 - 17:05 UTC
Investigating
We are investigating reports of slow downs in our US region
Posted Apr 16, 2020 - 16:22 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region) and Teamwork Desk (Teamwork Desk - US Region).