Teamwork Desk - Inbound Mail Processing Service Interruption
Incident Report for Teamwork.com
Resolved
Service has been restored. We apologise for interruption to service.
Posted Aug 01, 2024 - 15:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2024 - 13:26 UTC
Identified
The issue has been identified and we're working with our provider to resolve ASAP.
Posted Aug 01, 2024 - 12:23 UTC
Investigating
We are currently investigating this issue.
Posted Aug 01, 2024 - 11:26 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).