We are investigating reports of issues signing up in our EU region
Incident Report for Teamwork.com
Resolved
We have fixed a service which was causing some users to experience an error when signing up in the EU region
Posted Oct 03, 2022 - 10:43 UTC
Investigating
We are investigating reports of issues signing up in our EU region
Posted Oct 03, 2022 - 09:31 UTC
This incident affected: Teamwork Projects (Teamwork Projects - EU Region).