Slow load
Incident Report for Teamwork.com
Resolved
This has now been resolved.
Posted Jul 11, 2022 - 09:22 UTC
Investigating
We are currently seeing issues in the EU regions, we are looking into it at the moment.
Posted Jul 11, 2022 - 09:17 UTC
This incident affected: Teamwork Projects (Teamwork Projects - EU Region), Teamwork Desk (Teamwork Desk - EU Region), and Teamwork Chat (Teamwork Chat - EU Region).