We are investigating reports of slow loading times for Teamwork Projects in our US region
Incident Report for Teamwork.com
Resolved
Teamwork Projects in our US region is operating normally now, after a period of high traffic.
Posted Sep 19, 2019 - 15:37 UTC
Investigating
We are investigating reports of slow loading times for Teamwork Projects in our US region
Posted Sep 19, 2019 - 14:37 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).