Degradated performance in the EU Region
Incident Report for Teamwork.com
Resolved
CDN issues in our EU region have been resolved
Posted Aug 03, 2021 - 09:36 UTC
Investigating
We are currently investigating this issue.
Posted Aug 02, 2021 - 16:05 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region), Teamwork Projects (Teamwork Projects - EU Region), and Teamwork Spaces (Teamwork Spaces - EU Region).