Intermittent Login Issues - US and EU regions
Incident Report for Teamwork.com
Resolved
Earlier our engineering team deployed a number of counter measures to combat increased levels of malicious traffic to our login endpoints. These measures have restored normal service. Our SRE team continue to monitor traffic patterns and service levels as a priority.
Posted May 13, 2024 - 16:01 UTC
Monitoring
Our engineering team have deployed measures to address increased volumes of malicious traffic to login endpoints. We're continue to monitor system performance.
Posted May 13, 2024 - 13:57 UTC
Investigating
We're investigating reports of intermittent login issues in our EU and US regions. Our engineering team are working to identify the root cause. Further updates to follow.
Posted May 13, 2024 - 12:17 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region, Teamwork Projects - EU Region), Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region), and Teamwork Spaces (Teamwork Spaces - US Region, Teamwork Spaces - EU Region).