We are investigating reports of connection issues for Teamwork Projects and Desk in our EU region
Incident Report for Teamwork.com
Resolved
Services remain stable now as connection levels return to normal in our EU region
Posted Apr 22, 2021 - 11:17 UTC
Monitoring
Services are returning to normal in the EU region now. We experienced an increase in connections to a database in the EU region causing some services to experience connection issues. We will continue to monitor for a time before clearing this incident fully.
Posted Apr 22, 2021 - 10:36 UTC
Identified
We are investigating reports of connection issues for Teamwork Projects and Desk in our EU region
Posted Apr 22, 2021 - 09:41 UTC
This incident affected: Teamwork Projects (Teamwork Projects - EU Region).