Loading Issues with Teamwork Chat

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 14:39 UTC

Investigating

We are currently experiencing loading issues with Teamwork Chat, our engineers are aware and investigating.
Posted Jul 03, 2025 - 14:28 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region).