We are seeing a delaying in processing Desk tickets.
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Oct 29, 2020 - 22:04 UTC
Update
We are continuing to investigate this issue.
Posted Oct 29, 2020 - 22:03 UTC
Update
We are continuing to investigate this issue but we're no longer seeing delays in the incoming Desk tickets.
Posted Oct 29, 2020 - 22:02 UTC
Investigating
We are seeing a delaying in receiving tickets in to Teamwork Desk due to an upstream provider
Posted Oct 29, 2020 - 20:20 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).