We are investigating reports of Teamwork Desk being offline in our US region
Incident Report for Teamwork.com
Resolved
Teamwork Desk in our US region is responding normally now. We experienced an issue with a 3rd party provider for recording performance metrics of our apps. We have by passed this for now while we debug the issue.
Posted Sep 20, 2019 - 08:34 UTC
Investigating
We are investigating reports of Teamwork Desk being offline in our US region
Posted Sep 20, 2019 - 05:27 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).