Sign in issues in the US
Incident Report for Teamwork.com
Resolved
This incident has been resolved
Posted Jun 21, 2021 - 19:34 UTC
Update
The issue has been identified and corrected.
Launchpad services are operating normally.
Posted Jun 21, 2021 - 19:33 UTC
Investigating
We are currently investigating this issue.
Posted Jun 21, 2021 - 19:11 UTC
This incident affected: Launchpad (Launchpad - US Region).