Connectivity issues with all services in the EU region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 03:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2021 - 03:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 21, 2021 - 01:15 UTC
This incident affected: Teamwork Chat (Teamwork Chat - EU Region), Teamwork CRM (Teamwork CRM - EU Region), Teamwork Desk (Teamwork Desk - EU Region), Teamwork Projects (Teamwork Projects - EU Region), and Launchpad (Launchpad - EU Region).