Connectivity issues for custom domains in the EU region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Apr 10, 2020 - 07:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2020 - 07:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 10, 2020 - 07:31 UTC
Investigating
We are currently investigating this issue.
Posted Apr 10, 2020 - 07:25 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region) and Teamwork Projects (Teamwork Projects - EU Region).