We are investigating reports of Teamwork Desk not responding in some geographical regions
Incident Report for Teamwork.com
Resolved
We have rolled back a Teamwork Desk deployment that was causing instability in some regions.
Posted Oct 30, 2019 - 11:19 UTC
Investigating
We are investigating reports of Teamwork Desk not responding in some geographical regions
Posted Oct 30, 2019 - 10:59 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).