We are working on resolving slow response times for Teamwork in our US region
Incident Report for Teamwork.com
Resolved
Teamwork is operating normally now in our US region.
Posted Nov 17, 2020 - 17:37 UTC
Identified
We are working on resolving slow response times for Teamwork in our US region
Posted Nov 17, 2020 - 17:10 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region), Teamwork Spaces (Teamwork Spaces - US Region), and Teamwork Projects (Teamwork Projects - US region).