We are currently having issues with sign-in service in our EU Region
Incident Report for Teamwork.com
Resolved
We have resolved connectivity issues that were impacting authentication in the EU region
Posted Apr 29, 2022 - 09:35 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 29, 2022 - 09:09 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 29, 2022 - 09:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 29, 2022 - 09:07 UTC
This incident affected: Launchpad (Launchpad - EU Region).