We are investigating reports of disconnects for Teamwork Chat in our US region
Incident Report for Teamwork.com
Resolved
We experienced an increase in Chat traffic causing our databases to lag for a moment. They have now recovered fully.
Posted Apr 21, 2021 - 15:28 UTC
Identified
We are investigating reports of disconnects for Teamwork Chat in our US region
Posted Apr 21, 2021 - 15:15 UTC
This incident affected: Teamwork Chat (Teamwork Chat - US Region).