We are investigating reports of some users unable to log in in our US region
Incident Report for Teamwork.com
Resolved
Some maintenance work was slowing down logins for a sub set of users which has now completed. A number of customers have responded reporting logins are responding quickly again.
Posted Mar 18, 2020 - 14:21 UTC
Investigating
We are investigating reports of some users unable to log in in our US region
Posted Mar 18, 2020 - 13:12 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).