We are investigating reports of users unable to log in to Teamwork Desk in our EU region
Incident Report for Teamwork.com
Resolved
We have deployed a fix for this issue in Teamwork Desk in our EU region. Limits have been put in place one one of our internal apps to avoid keeping the database too busy at peak times.
Posted Apr 20, 2020 - 11:10 UTC
Monitoring
We have identified the cause of the intermittent issues for Teamwork Desk in our EU region and we are working on deploying a change to fix this issue fully.
Posted Apr 20, 2020 - 10:22 UTC
Identified
We are investigating reports of users unable to log in to Teamwork Desk in our EU region
Posted Apr 20, 2020 - 08:38 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region).